sudo apt-get install libxtst-dev:i386
18 czerwca 2014
libXtst.so.6 cannot open shared object file error during Oracle Installation
12 czerwca 2014
ubuntu – pakiety
instalacja
dpkg -i pakiet.deb
usunięcie
dpkg -r pakiet.deb
rekonfiguracja
dpkg -reconfigure pakiet.deb
3 czerwca 2014
Solaris – Weblogic
MW_HOME/utils/quickstart/quickstart.sh
I fixed it by add to top of c:\users{user}\AppData\Roaming\JDeveloper\system{version}\DefaultDomain\bin\setDomainEnv.cmd:
set SUN_JAVA_HOME=E:\Oracle\Java\jdk1.6.0_37
set JAVA_VENDOR=Sun
Solaris – JAVA
- Set JAVA_HOME to /usr/j2se.
- In a C shell environment:
# setenv JAVA_HOME /usr/j2se
- In a Bourne or Korn shell environment:
# JAVA_HOME=/usr/j2se # export JAVA_HOME
Tip – Add the appropriate statement to your .login or .cshrc file. - In a C shell environment:
- Add /usr/j2se/bin to your system path.
- Place /usr/j2se/bin in your PATH before /usr/bin.
- Place /usr/bin in your PATH before /usr/ucb
Source: http://docs.oracle.com/cd/E19062-01/sun.mgmt.ctr36/819-5418/system-prep-proc-3/index.html
java -version
java -d64 -version
zcat jdk-6 <update> -solaris-i586.tar.Z | tar -xf -
pkgadd -d . SUNWj6rt SUNWj6dev SUNWj6cfg SUNWj6man SUNWj6dmo
pkgrm SUNWj6rt SUNWj6dev SUNWj6cfg SUNWj6man SUNWj6dmo
64Bit – /usr/jdk/jdk1.6.0
32Bit – /usr/jdk/jdk1.6.0
/usr/java
2 czerwca 2014
Solaris init script
Oracle on Solaris 10 : Fixing the ‘ORA-27102: out of memory’ Error
Adding Swap Space on a Solaris System
- Become a superuser (root) by typing:
% su Password: root-password
- Create a file in a selected directory to add swap space by typing:
mkfile number[m|k|b] /directory/swap-file-name
where number is an amount of swap space, followed by either m for megabyte, k for kilobyte, or b for block. The directory is a directory in which you have permission to add swap space. The swap-file-nameis the name of the swap file you are creating.
For example, to create a 16-megabyte swap file named 16mswapin the foodirectory, type the following:
mkfile 16m /foo/16mswap
See the mkfile(1M) man page for more information.
- Verify that the file was created by typing:
ls -l /directory/swap-file-name
The new file appears in the directory. For example:
ls -l /foo/16mswap -rw------T 1 root other 16777216 Dec 12 14:24 /foo/16mswap
- Run the swap command to specify the additional swap space by typing:
swap -a /directory/swap-file-name
- Verify that the extra swap space was added by typing:
swap -s
The output shows the allocated swap space. For example:
swap -s total: 289336k bytes allocated + 27008k reserved = 316344k used, 298336k available
source: http://docs.oracle.com/cd/E24457_01/html/E21988/gipoj.html
ASM
http://blog.sina.com.cn/s/blog_4ea0bbed0100zd6d.html
http://docs.oracle.com/cd/E11882_01/server.112/e18951/asmdiskgrps.htm#OSTMG94156
1 czerwca 2014
Solaris – managing projects.
http://docs.oracle.com/cd/E19044-01/sol.containers/817-1592/rmtaskproj.task-10/index.html
projadd -c “Oracle Default Project” group.dba
In order to make Oracle to use this project by default you need to modiy the file /etc/user_attr file. Add the following line to /etc/user_attr
oracle::::project=group.dba
Oracle will now use this project group by default.
To modify the value of max-shm-memory to 6 GB:
# prctl -n project.max-shm-memory -v 6gb -r -i project group.dba
http://oraclehack.blogspot.com/2007/08/installing-10g-on-solaris-10.html
projmod -sK “project.max-shm-memory=(privileged,10G,deny)” group.dba